DNS RFC Reference Library
Browse technical standards and reference documents related to the Domain Name System (DNS). Select an RFC number to open the corresponding text document in a new tab.
| RFC | Description |
|---|---|
| RFC 1034 | Domain Names – Concepts and Facilities |
| RFC 1035 | Domain Names – Implementation and Specification |
| RFC 1183 | DNS RR Definitions |
| RFC 1591 | Domain Name System Structure and Delegation |
| RFC 1706 | DNS NSAP Resource Records |
| RFC 1794 | DNS Support for Load Balancing |
| RFC 1876 | Expressing Location Information in the Domain Name System |
| RFC 1912 | Common DNS Operational and Configuration Errors |
| RFC 1982 | Serial Number Arithmetic |
| RFC 1995 | Incremental Zone Transfer in DNS |
| RFC 1996 | A Mechanism for Prompt Notification of Zone Changes (DNS NOTIFY) |
| RFC 2136 | Dynamic Updates in the Domain Name System (DNS UPDATE) |
| RFC 2181 | Clarifications to the DNS Specification |
| RFC 2230 | Key Exchange Delegation Record for the DNS |
| RFC 2308 | Negative Caching of DNS Queries (DNS NCACHE) |
| RFC 2317 | Key Exchange Delegation Record for the DNS |
| RFC 2536 | DSA KEYs and SIGs in the Domain Name System (DNS) |
| RFC 2539 | Storage of Diffie-Hellman Keys in the Domain Name System (DNS) |
| RFC 2540 | Detached Domain Name System (DNS) Information |
| RFC 2606 | Reserved Top Level DNS Names |
| RFC 2671 | xtension Mechanisms for DNS (EDNS0) |
| RFC 2672 | Non-Terminal DNS Name Redirection |
| RFC 2673 | Binary Labels in the Domain Name System |
| RFC 2694 | DNS extensions to Network Address Translators (DNS_ALG) |
| RFC 2782 | A DNS RR for specifying the location of services (DNS SRV) |
| RFC 2845 | Secret Key Transaction Authentication for DNS (TSIG) |
| RFC 2874 | NS Extensions to Support IPv6 Address Aggregation and Renumbering |
| RFC 2930 | Secret Key Establishment for DNS (TKEY RR) |
| RFC 2931 | DNS Request and Transaction Signatures ( SIG(0)s ) |
| RFC 3007 | Secure Domain Name System (DNS) Dynamic Update |
| RFC 3110 | DNS Request and Transaction Signatures ( SIG(0)s ) |
| RFC 3123 | A DNS RR Type for Lists of Address Prefixes (APL RR) |
| RFC 3225 | Indicating Resolver Support of DNSSEC |
| RFC 3226 | DNSSEC and IPv6 A6 aware server/resolver message size requirements |
| RFC 3363 | Dynamic Delegation Discovery System (DDDS) |
| RFC 3401 | Dynamic Delegation Discovery System (DDDS) |
| RFC 3402 | Dynamic Delegation Discovery System (DDDS) |
| RFC 3403 | Default Address Selection for Internet Protocol version 6 (IPv6) |
| RFC 3404 | DNS Extensions to Support IP Version 6 |
| RFC 3405 | Generic Security Service Algorithm for Secret Key Transaction Authentication for DNS (GSS-TSIG) |
| RFC 3425 | Threat Analysis of the Domain Name System (DNS) |
| RFC 3484 | A Method for Storing IPsec Keying Material in DNS |
| RFC 3492 | Resource Records for the DNS Security Extensions |
| RFC 3596 | Using DNS to Securely Publish Secure Shell (SSH) Key Fingerprints |
| RFC 3597 | What's in a Name: False Assumptions about DNS Names |
| RFC 3645 | Storing Certificates in the Domain Name System (DNS) |
| RFC 3761 | Sender Policy Framework (SPF) for Authorizing Use of Domains in E-Mail, Version 1 |
| RFC 3833 | The DNSSEC Lookaside Validation (DLV) DNS Resource Record |
| RFC 3958 | Minimally Covering NSEC Records and DNSSEC On-line Signing |
| RFC 4025 | Operational Considerations and Issues with IPv6 DNS |
| RFC 4033 | Domain Name System Uniform Resource Identifiers |
| RFC 4034 | Use of SHA-256 in DNSSEC Delegation Signer (DS) Resource Records (RRs) |
| RFC 4035 | The Role of Wildcards in the Domain Name System |
| RFC 4255 | HMAC SHA TSIG Algorithm Identifiers |
| RFC 4343 | DNSSEC Operational Practices |
| RFC 4367 | Observed DNS Resolution Misbehavior |
| RFC 4398 | A DNS Resource Record (RR) for Encoding Dynamic Host Configuration Protocol (DHCP) Information (DHCID RR) |
| RFC 4408 | ENUM Validation Architecture |
| RFC 4431 | The ENUM Dip Indicator Parameter for the "tel" URI |
| RFC 4470 | Domain-Based Application Service Location Using URIs and the Dynamic Delegation Discovery Service (DDDS) |
| RFC 4472 | DomainKeys Identified Mail (DKIM) Signatures |
| RFC 4501 | A Method for Storing IPsec Keying Material in DNS |
| RFC 4509 | DNS Security (DNSSEC) Opt-In |
| RFC 4592 | IANA Registration for vCard Enumservice |
| RFC 4635 | IANA Registration for Enumservice 'XMPP' |
| RFC 4641 | Requirements Related to DNS Security (DNSSEC) Trust Anchor Rollover |
| RFC 4697 | DNS Name Server Identifier (NSID) Option |
| RFC 4701 | Automated Updates of DNS Security (DNSSEC) Trust Anchors |
| RFC 4725 | Requirements for a DomainKeys Identified Mail (DKIM) Signing Practices Protocol |
| RFC 4759 | A Telephone Number Mapping (ENUM) Service Registration for Instant Messaging (IM) Services |
| RFC 4848 | Infrastructure ENUM Requirements |
| RFC 4871 | DNSSEC Lookaside Validation (DLV) |
| RFC 4955 | ENUM Validation Information Mapping for the Extensible Provisioning Protocol |
| RFC 4956 | ENUM Validation Token Format Definition |
| RFC 4969 | DNS Security (DNSSEC) Hashed Authenticated Denial of Existence |
| RFC 4979 | 6to4 Reverse DNS Delegation Specification |